ospf network definition for adding all interfaces / default route

September 19th, 2008

What’s the difference?

router ospf 1

network 0.0.0.0 0.0.0.0 area 0

vs.

router ospf 1

network 0.0.0.0 255.255.255.255 area 0

Both add all existing interfaces into area 0 and all later added interfaces also. Both statements are valid.

For the default route it seems the same:

ip route 0.0.0.0 0.0.0.0 f1/1

vs.

ip route 0.0.0.0 255.255.255.255 f1/1

both work, sending traffic to the default gatewayf f1/1.

What IOS does not permit is a mixture for example.:

0.0.0.0 0.0.255.255

or

0.0.0.0 0.255.255.255

SW1(config)#ip route 0.0.0.0 0.0.255.255 f1/1
%Inconsistent address and mask

Both statements are the same. Since both have the same logical „AND“ing result for the host part, namely „0“.

0 0 0 0 0 0 0 0

1 1 1 1 1 1 1 1

———————-

0 0 0 0 0 0 0 0

vs.

0 0 0 0 0 0 0 0

0 0 0 0 0 0 0 0

———————-

0 0 0 0 0 0 0 0

eigrp and leak-map

September 1st, 2008

A quite new feature for eigrp is the possibility of a leak-map. It’s simmiliar to the unsupress-map in BGP. As there is different behavior for the route-map statement if missconfigured, there is a way to send the summary and also all routes included in the summary.

ip summary-address eigrp 1 10.0.0.0 255.0.0.0 leak-map RM_LEAK

route-map RM_LEAK

An empty route-map will send the summary and also all component routes.

If the route-map is missing completelyit has no effect and the summary is send.

This would be a way to send the summary and also all components with the summary.

ip summary-address eigrp 1 10.0.0.0 255.0.0.0 leak-map RM_LEAK

ip prefix-list PRE_150 seq 5 permit 150.1.2.0/24

route-map RM_LEAK

match ip address prefix-list PRE_150

Like this only the summary 150.1.0.0/16 and the 150.1.2.0/24 network will be send to the neighbor.

Source:

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gt_esflr.html

UniverCD in the lab

August 27th, 2008

Cisco Announces to discontinue their univercd in the lab. Starting from the 24.9. this year, only

http://cisco.com/web/psa/products/tsd_products_support_configure.html

will be available as documentation.

Source:

http://www.cisco.com/web/learning/le3/ccie/rs/index.html

LockLizard with new IE products, beta V5 workbook

Juli 12th, 2008

I`m using linux only on my laptop. Sometimes i`m not able to connect to the internet maybe for about 2-3 weeks, for example when being on holiday in a little town with no access to internet at all, like this year. But IE is now using security protection for their files, that will prevent me from using these documents. I don`t understand their orientation. I have paid for these files and i don`t want the be treated as a someone untrustable. And also i want to use these documents to ease my work and not to make my work more complicated. With the new protection software you have to connect every week once to the internet to be able to read them. Also LockLizard only works with Windows.

They suggest using vmware with xp or vista on linux to unprotect these files with the new locklizard software. It`s like if you by a book and you will not be able to read it, if you don`t update the store where you bought it once a week, what pages are you reading right now.

I would like to change to another workbook vendor, but seems like that others are not that easy to setup on dynamips. IPexpert said, that they don`t support dynamips. They will send a full hardisc with their materials. But this should work with linux also.

Source:

http://www.internetworkexpert.com/locklizardfaq.htm

ip default-network vs. ip default-gateway

Juli 10th, 2008

Every time a come across these commands i wonder what is the difference. Now i have looked it up … 🙂

„ip route 0.0.0.0 0.0.0.0 x.x.x.x“ and „ip default-network x.x.x.x“ are the same. They are used when „ip routing“ is enabled. If not use „ip default-gateway x.x.x.x“.

If you add the ip default-network command in EIGRP, you will see the D* in your routing table, as the candidate default. Even if this is not a route to null, it will be used from all routers as it. Seems like a remaining, from the IGRP times, when no summary with 0.0.0.0 0.0.0.0 was possible.

Source:

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012d8f7.shtml#qa7

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

Failed my second lab attempt and what comes next?

Mai 17th, 2008

I have a child and i really enjoy it to be with him. Configuring devices is still quite nice, but it will not be as good as playing with my son. So he learns the most in his first year.

How to motivate for the next try? Learning from the last attempts is quite difficult for me. This attempt was quite strange. But maybe i did not had enough sleep the days before my last attempt.

So what to learn from my last attempt? The sections i did not thought i was right, i was 100% and the others that have been my stronger topcis, i did not came above 2/3 percent. All over the other, i was better on my first attempt.

What i think i can learn about my last attempt is that, sometimes i think the question is more difficult that it is at least. So i think i need more practise in some certain topics to make sure to be more confident about the configuration. I think i test to much and i heasitate to much of choosing the right way.

So here is my todolist of what to improve next time and how to do it at my next and third attempt.

  • become more self confident about the configuration i use
  • improve on certain topics, i still have some weak topics and i sometimes hope they will not be present, but this is just a hope 🙂
  • maybe more improvement on my speed, but like last time i wasn’t to slow, but might be even quicker, maybe i can try to finisch most of the config before lunch
  • just do more practise and test more different technices
  • get more sleep the days before my next attempt
  • look again through the topics and again starting first with an overview of things, then go into detail

Here is what was good and what i will do again like last time:

  • make a diagramm from the layer 2 and layer 3 topology and start reading the different questions over
  • don’t spend to much time on diagramms but make them readable on the first try
  • use earplugs 🙂

But how to motivate for the next attempt. Two weeks have passed from my last attempt now. And still i feel like i have to move a rock on my next attempt. I need a bit more to recover before i start it all over again, but i will do it again and i won’t wait to long this time.

As last time the proctor was really good, at this attempt i got the feeling, better not to ask and proctors have been absent from the labroom for at least 30 minutes. I did not feel good this time. But it have been also more participants this time.

Cisco has not really commented about the dynamips usage as a learning tool. But since the cisco commandline will spread more and more with this tools, it maybe the reason why they don’t comment much on using dynamips.

Even now it’s possible with pemu to emulate a pix. Many using this also already as a learning tool.

I will start it all over again and this time i will take the lab, when i’m ready. And this will be when i know i will pass.

did my family „ccie“ :-)

Mai 10th, 2008

On the 17.4.08 i got a son and became father. We are all doing well and life got us back again. It was one of my most wonderful moments in life.

lian3.jpg

Got my last holiday yesterday and will start work next week on tuesday, because monday is an official holiday here in germany.

Sometimes i was already expecting this would never happen any more. But on times as you do not expect it, it maybe once will and this is now the case.

I also got married in the meantime. But this nearly became a sidetone, but makes the family story complete.

did my lab today

April 28th, 2008

but i probably failed.

I found it more difficult than the last time. There had been a lot of questions and i wasn`t able to finish all topics. I missed about 3 to 4 and others i`m not sure. So i will probably not pass. Did not get the mail yet, but i expect it like that. Now i`m just tired and want to sleep. But i will do it again.

ip igmp snooping for 224.0.0.0 to 224.0.0.255

April 23rd, 2008

I have read about this subnet range, it`s not possible to disable the snooping feature on a switch. So routing protocols (like OSPF or EIGRP) are always forwarded to other ports regardless the snooping feature. Is that true? Someone with more informations on that.

——————————————————
In general, addresses from 224.0.0.1 to 224.0.0.255 are reserved and used by various protocols (standard or proprietary, such as Hot Standby Router Protocol (HSRP)). Cisco recommends that you not use these for GDA in a multicast network. CGMP and IGMP snooping do not work with this reserved address range.
——————————————————

Source:

http://www.cisco.com/warp/public/473/22.html

new dynamips version 0.2.8-RC2

April 23rd, 2008

Thanks very much to the author Chris (Christophe Filot) for dynamips. Which is very helpfull preparing for the lab.

Mostly bugfixes, but also now with ISL trunking support.

GNS3 is also a nice tool for drag and drop a topology with the needed devices and IOS versions. It`a still a little bugy sometime, but if you can live with that, give it a try. It`s really nice.

Source:

http://www.ipflow.utc.fr/blog/?p=52

Here are the binaries:

Download x86 Linux:

http://www.ipflow.utc.fr/dynamips/dynamips-0.2.8-RC2-x86.bin

Download x86_64 Bit Linux:

http://www.ipflow.utc.fr/dynamips/dynamips-0.2.8-RC2-amd64.bin

Download Win32 Version:

http://www.ipflow.utc.fr/dynamips/dynamips-0.2.8-RC2-cygwin.zip

GNS3:

www.gns3.net