Archive for the ‘IGP Routing’ Category

What are floating routes?

Montag, September 18th, 2006

Floating routes are somtetime static routes with another administrativ distance. These routes disapear, when dynamic routes are no longer valid. This could be a technique to prove certain rechability for networks. Floating means, that they are there but you can’t see them until they get valid.

If there is for example a dynamic default route is learned from EIGRP with Administrativ distance 90 or for external EIGRP routes with AD 170, then you could place a static route with „ip route 0.0.0.0 0.0.0.0 s0/0 171“, so that it will apear in the routing table, when the AD 90 or 170 default route does not longer exists.
That’s called a floating route.

ip address classes

Mittwoch, Juli 19th, 2006

Class A: 0.0.0.0 – 127.255.255.255
Class B: 128.0.0.0 – 191.255.255.255
Class C: 192.0.0.0 – 223.255.255.255
Class D: 224.0.0.0 – 239.255.255.255
Class E: 240.0.0.0 – 255.255.255.255

private IP address ranges (RFC1918)

Mittwoch, Juli 19th, 2006

These are private IP address range as described in RFC 1918. They are not routed on the internet and they are for private or internal use only.

10.0.0.0 – 10.255.255.255        or 10.0.0.0/8
172.16.0.0 – 172.31.255.255     or 172.16.0.0/12
192.168.0.0 – 192.168.255.255  or 192.168.0.0/16

Source:

ftp://ftp.rfc-editor.org/in-notes/rfc1918.txt

redistribution and metrics

Mittwoch, Juli 19th, 2006

With redistribution it is necessary to take care of metrics from different routing protocols.

RIP uses Hop count

EIGRP uses a composition of bandwidth and delay

OSPF uses bandwidth

BGP consists of an arbitrary unit number

It is important to know how to adjust the metrics for redistributed routing protocols. Because they are not compatible by default, it necessary to convert them between the protocols.

OSPF has two differnet external metric types. Type 1 adds the metric defined in the OSPF domain to the metric of the boarder router. Type 2 ignore internal metric in the OSPF domain.

redistribution eigrp -> ospf

Mittwoch, Juli 19th, 2006

router ospf 1

redistribute eigrp [eigrp process id] metric [value] [subnets]

for example

redistribute eigrp 1 metric 1 subnets

The subnets variable is responsible for redistributing subnetted networks. Without this variable, only networks that are not subnetted are redistributed.

metric, a definition

Mittwoch, Juli 19th, 2006

Routing protocols need to determin the best way to reach a certain address. So in the case there is more than one possibility, the routing algorithm looks up a metric value. The differnent routing protocols have different metrics. They can also combine differnet metric in a so calles hybrid metric. These are metrics used:

  • path length
  • reliabilty
  • delay
  • bandwidth
  • load
  • communication cost

path lenght could be assigned as an arbitrary cost to each network link and then is the summ of the cost of each link traversed.

RIP for example take the hop count as metric. It’s the number of passes through routers a packet takes.

reliability refers to a dependability of each network link.

delay defines the value a packet take from source to destination. It’s a conglomerate of several variables and a common metric

bandwidth refers to the available capacity of a link.  It does not necessarily provide better routes, because links can be busy and the time could be greater.

load the degree a network resource is busy, which might be processor load

communication cost is the possibility to avoid sending data over costful lines, that for example do not belong to your own ones. It meight be more expensive to send over other provider path’s, then your own.
Source:

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/routing.htm#xtocid15

simple layer 3 next hop forwarding

Donnerstag, Juli 13th, 2006

to forward a certain destination address over another
next hop use the following:

access-list 101 permit ip any host 192.168.1.2

route-map layer3 permit 10
match ip address 101
set ip next-hop 192.168.1.3

and in global config mode you need:

ip local policy  route-map NAME
This forwards a packet to next hop 1.3 if someone tries
to reach 1.2

Automatic Route Summarisation

Dienstag, Mai 23rd, 2006

The following Routing Protocols do automatic route summarisation by default:

  • EIGRP
  • IGRP
  • RIP v1

Route summarization

Freitag, Mai 19th, 2006

Routing protocols summarize networks into supernetworks to keep routing tables small.

Rip does this by default and you can’t turn it off.

EIGRP does this also by default. But you can turn it of with „no auto-summary“

And last but not least IGRP does this also by default.

OSPF <-> RIP

Freitag, Mai 19th, 2006

This is an simple example of redistributing ospf to rip and vica versa.

A Borderrouter having two interfaces. One Interface in the OSPF area 0 and one interface in the RIP area.

interface Ethernet0
ip address 192.168.3.2 255.255.255.0
!
interface Serial1
ip address 192.168.4.1 255.255.255.0
!

router ospf 1
log-adjacency-changes
redistribute rip
network 192.168.3.0 0.0.0.255 area 0
default-metric 64000
!
router rip
redistribute ospf 1
network 192.168.4.0
default-metric 4

Configuring Routing from ospf to rip is quite easy. Just use the „rediribute rip“ command. And maybe the „default-metric“ command.

With the redistribution from ospf to rip you have use also a default-metric. I took 4.

And then you will see, that like a magic update, the routes appear under both routing areas.